William "Chops" Westfield wrote: > Unless this is a standard and common construct where you work or go to > school, I urge conversion to the MUCH more common: "for (i=0; i<50; > i++)" form. Any reasonable compiler should produce similar code On most smaller micros, there is a difference between upcounting loops and downcounting loops. A "decrement and branch on zero" instruction is frequently available with a single instruction cycle, whereas an "increment and branch if equal to value" instruction usually needs to be coded in several assembly instructions. So a (slightly better, and possibly more used in good code) way to write it your style would be: for( i=50; i!=0; --i). And this should really compile to the same as for( i=50; --i; ). Gerhard -- http://www.piclist.com PIC/SX FAQ & list archive View/change your membership options at http://mailman.mit.edu/mailman/listinfo/piclist