Jason, If I may enter my 2 cents worth......... What makes it messy for me is that..... There is no white space between lines. It's like one solid mass of text. So the first think I would do is to add blank lines between sections of code that performs a given function, or works on different pins, etc. And the second thing is more a matter of documentation etiquitte. That is your comments basically explain the individual instruction, and not what the section of code is supposed to accomplish. ie..MOVLW 0x40, W I (anyone I dare say) could tell that this loads the value 40 hex into the W register. What the comment should state in this case is why is W loaded with that value. Believe me, anyone who works with your code after you have finished your current round of coding will appreciate your comments more if they explain the function of the code blocks, and not just the individual instructions. As a matter of fact, several weeks from now if you were to go back to this code to make a modification for some reason, would you remember why you did a particular operation the way you did it without the reminder from the comments? Anyway, that's my take on the situation. And I'm sure most people here will agree. Regards, Jim ----- Original Message ----- From: "Jason Hsu" To: "Microcontroller discussion list - Public." Sent: Saturday, June 14, 2008 1:37 PM Subject: Re: [OT]Looking for an embedded engineering job > On 6/12/08, Vitaliy wrote: >> >> What kind of work have you done in the past? Why have you decided to go >> into >> embedded engineering? Where is your resume? :) >> > Although I am not posting my resume on Monster or on my web site, I > will email it to any of you who are interested. > >>> My report on the SWR/wattmeter is at: >>> http://www.jasonhsu.com/swrwatt.html >> >> Looks like you did this project in 2003. Do you have examples of more >> recent >> projects? >> > Actually, I worked on the original version in 2003. I recently > completed a new version that uses a PIC microcontroller as a > replacement for the LM3914 and LM3915. (Thanks for the pointer. I've > updated the web page to make this clear.) >> >> Other people may have a different opinion, but IMHO the code looks rather >> messy and difficult to follow. You can greatly improve it by making >> better >> use of whitespace (and perhaps a better naming convention). >> > What makes the code messy and difficult to follow? Where can I find > examples of better code? > > -- > Jason Hsu > http://www.jasonhsu.com/swrwatt.html > http://www.jasonhsu.com/swrwatt-source_code.txt > NOTE: I am seeking employment as an embedded electronics engineer. > -- > http://www.piclist.com PIC/SX FAQ & list archive > View/change your membership options at > http://mailman.mit.edu/mailman/listinfo/piclist > -- http://www.piclist.com PIC/SX FAQ & list archive View/change your membership options at http://mailman.mit.edu/mailman/listinfo/piclist