I wrote isr_exit bcf intcon,2 ; Clear interrupt bit *** bcf intcon,t0ie *** Should be bcf intcon,t0if, not t0ie You can re-define SFR bits with names that are more appropriate for a particular program, which may help debugging. It will make the program more readable, but you have to consider portability to other PICs sometimes For example, say you are counting something like mains cycles on portb,0 using INT. Which is intcon,1 / intcon,intf #define mains_cycle intcon,intf ;or whatever name you choose btfss mains_cycle eg if polling (interrupts disabled - you could also test portb,0 itself) or flag testing in an ISR that could be entered via more than one source -- http://www.piclist.com PIC/SX FAQ & list archive View/change your membership options at http://mailman.mit.edu/mailman/listinfo/piclist