> I don't think that something like > if ( NULL == ( pObject = methodThatReturnObject( .... ) ) ) { > ; > } > is that bad or hard to understand. Defintily nothing to be shot for... ;-) Another argument is a "while" statement like: while(0 < (count = GetNextGroup())) { : if(0 = = foo) continue; : } The only alternative is to assign "count" before the "while" loop and in the "continue" test and at the end of the loop: count = GetNextGroup(); while(0 < count) { : if(0 = = foo) { count = GetNextGroup(); continue; } : count = GetNextGroup(); } That's kinda ugly to maintain. Win Wiencke Image Logic Corporation _______________________________________________ http://www.piclist.com View/change your membership options at http://mailman.mit.edu/mailman/listinfo/piclist