I think that the following shortcut, though comman, can be dangerous. > > Also you will have an easier time with code maintenance if you do the > > following: > > #define CLK PORTA, 1 > > #define DQ PORTA, 0 I prefer to replace each argument (in this case, PORTx and BITx) with separate equivalents. This is valid, but I find that using one word (e.g. CLK) to represent two items can make debugging more difficult because ones eye doesn't learn the rythym of the syntax. (If that makes any sense). When I'm debugging, this helps me to check each part of the instruction for accuracy. (Not that anyone asked, but ... hey). Andrew ________________________________________________ Get your own "800" number Voicemail, fax, email, and a lot more http://www.ureach.com/reg/tag -- http://www.piclist.com#nomail Going offline? Don't AutoReply us! email listserv@mitvma.mit.edu with SET PICList DIGEST in the body