Along these lines, what is your favourite naming convention/style for variables? Say you're referring to the maximum temperature read from channel 1 of the internal ADC. Would you choose: 1) float max_temperature 2) float MaximumTemperature 3) float MT 4) float mtAD1 5) float T 6) temperature_type_floating_point Maximum_Temperature_Channel_1; We try to reserve upcase names for constants (#DEFINE, etc), and ALWAYS AVOID MIXED CASE NAMES (makes signs to ward off EVIL.) So probably float temp_max; or float max_temp; Function names eventually need prefixes to identigy where and what they're associated with, and structure members need the structure type in a prefix, so we try to have temp_get_max(...) temp_get_min(...) temp_set(...) instead of get_max_temp()/etc BillW -- http://www.piclist.com hint: The list server can filter out subtopics (like ads or off topics) for you. See http://www.piclist.com/#topics