> > This would make the code so much easier to read, > especially re banking issues, and just let the > parser handle it. What about: > btfss reg2,5 ; > goto bit_clear ; > goto bit_set ; > > could be replaced with: > BR_BIT reg2,5 bit_set ; > BR_NBIT bit_clear ; > > So it makes sense to suggest mnemonics for all > goto or skip PAIRS?? > -Roman > Yes. But making the pre-processed code look more like C would be even better. Why not make it look like: IF reg2,5 goto bit_set ELSE goto bit_clear This makes the code much more readable -- http://www.piclist.com hint: The list server can filter out subtopics (like ads or off topics) for you. See http://www.piclist.com/#topics